import Foundation
let pattern = #"^\{1:.*\{2:.*\{3:.*\{4:.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{1:F21CITICCIMMBL0107000001}{2:O2991405210107CITILUL0MBL01070000012101071405N}{3:{108:0000000000000114}}{4:
:20:401648471
:21:FT-TRN1234567890
:79:/ACK/Response Code 200
SCAR Response
Received
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)