const regex = /^\{1:.*\{2:.*\{3:.*\{4:.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\{1:.*\\{2:.*\\{3:.*\\{4:.*', 'gm')
const str = `{1:F21CITICCIMMBL0107000001}{2:O2991405210107CITILUL0MBL01070000012101071405N}{3:{108:0000000000000114}}{4:
:20:401648471
:21:FT-TRN1234567890
:79:/ACK/Response Code 200
SCAR Response
Received
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}