re = /^\{1:.*\{2:.*\{3:.*\{4:.*/m
str = '{1:F21CITICCIMMBL0107000001}{2:O2991405210107CITILUL0MBL01070000012101071405N}{3:{108:0000000000000114}}{4:
:20:401648471
:21:FT-TRN1234567890
:79:/ACK/Response Code 200
SCAR Response
Received
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end