#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:00|\+)58)(?:4(?:1[246]|2[46]))\d{7}$"
Local $sString = "04241234567" & @CRLF & _
"+584241234567" & @CRLF & _
"4241234567" & @CRLF & _
"(424)123.41.25" & @CRLF & _
"" & @CRLF & _
"04141234567" & @CRLF & _
"+584141234567" & @CRLF & _
"4141234567" & @CRLF & _
"(414)123.41.25" & @CRLF & _
"" & @CRLF & _
"04121234567" & @CRLF & _
"+584121234567" & @CRLF & _
"4121234567" & @CRLF & _
"(412)123.41.25" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")