package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:00|\+)58)(?:4(?:1[246]|2[46]))\d{7}$`)
var str = `04241234567
+584241234567
4241234567
(424)123.41.25
04141234567
+584141234567
4141234567
(414)123.41.25
04121234567
+584121234567
4121234567
(412)123.41.25
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}