import Foundation
let pattern = #"^(?:(?:00|\+)58)(?:4(?:1[246]|2[46]))\d{7}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
04241234567
+584241234567
4241234567
(424)123.41.25
04141234567
+584141234567
4141234567
(414)123.41.25
04121234567
+584121234567
4121234567
(412)123.41.25
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)