using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:00|\+)58)(?:4(?:1[246]|2[46]))\d{7}$";
string input = @"04241234567
+584241234567
4241234567
(424)123.41.25
04141234567
+584141234567
4141234567
(414)123.41.25
04121234567
+584121234567
4121234567
(412)123.41.25
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}