const regex = /^(?:(?:00|\+)58)(?:4(?:1[246]|2[46]))\d{7}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:00|\\+)58)(?:4(?:1[246]|2[46]))\\d{7}$', 'gm')
const str = `04241234567
+584241234567
4241234567
(424)123.41.25
04141234567
+584141234567
4141234567
(414)123.41.25
04121234567
+584121234567
4121234567
(412)123.41.25
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}