const regex = /^(?![\S\s]*should not exist)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![\\S\\s]*should not exist)', 'i')
const str = `This is a block of text
with many new lines
but in this block
some words should not exist
such as the line above this one`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}