import re
regex = re.compile(r"^(?![\S\s]*should not exist)", flags=re.IGNORECASE)
test_str = ("This is a block of text\n"
"with many new lines\n"
"but in this block\n"
"some words should not exist\n"
"such as the line above this one")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")