using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"if %{HTTP_HOST} regimatch t-sapportal.heijmans.com [AND]
if %{SERVER_PORT} = 7000
SetHeader x-sap-webdisp-target-sid HET";
string input = @"hu Jan 16 2018 00:15:06 mailsv1 sshd[5258]: Failed password for invalid user testuser from 194.8.74.23 port 3626 ssh2";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}