package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`if %{HTTP_HOST} regimatch t-sapportal.heijmans.com [AND]
if %{SERVER_PORT} = 7000
SetHeader x-sap-webdisp-target-sid HET`)
var str = `hu Jan 16 2018 00:15:06 mailsv1 sshd[5258]: Failed password for invalid user testuser from 194.8.74.23 port 3626 ssh2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}