$re = '/if %{HTTP_HOST} regimatch t-sapportal.heijmans.com [AND]
if %{SERVER_PORT} = 7000
SetHeader x-sap-webdisp-target-sid HET/';
$str = 'hu Jan 16 2018 00:15:06 mailsv1 sshd[5258]: Failed password for invalid user testuser from 194.8.74.23 port 3626 ssh2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);