import re
regex = re.compile((r"if %{HTTP_HOST} regimatch t-sapportal.heijmans.com [AND]\n"
r"if %{SERVER_PORT} = 7000\n"
r"SetHeader x-sap-webdisp-target-sid HET"))
test_str = "hu Jan 16 2018 00:15:06 mailsv1 sshd[5258]: Failed password for invalid user testuser from 194.8.74.23 port 3626 ssh2"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")