package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\/(.+?)){2}\/`)
var str = `source = shuttle(Oct1-3).zip:./shuttle/5720/LOG/shuttle_log.20171002
source = shuttle_3.zip:./shuttle_3/5720/LOG/shuttle_log.20171011
source = shuttle_3.zip:./isNOT/shuttle_3/5720/LOG/shuttle_log.20171011`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}