import Foundation
let pattern = #"(?:\/(.+?)){2}\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
source = shuttle(Oct1-3).zip:./shuttle/5720/LOG/shuttle_log.20171002
source = shuttle_3.zip:./shuttle_3/5720/LOG/shuttle_log.20171011
source = shuttle_3.zip:./isNOT/shuttle_3/5720/LOG/shuttle_log.20171011
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)