import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\/(.+?)){2}\\/";
final String string = "source = shuttle(Oct1-3).zip:./shuttle/5720/LOG/shuttle_log.20171002 \n"
+ "source = shuttle_3.zip:./shuttle_3/5720/LOG/shuttle_log.20171011\n"
+ "source = shuttle_3.zip:./isNOT/shuttle_3/5720/LOG/shuttle_log.20171011";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}