// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\/(.+?)){2}\/").unwrap();
let string = "source = shuttle(Oct1-3).zip:./shuttle/5720/LOG/shuttle_log.20171002
source = shuttle_3.zip:./shuttle_3/5720/LOG/shuttle_log.20171011
source = shuttle_3.zip:./isNOT/shuttle_3/5720/LOG/shuttle_log.20171011";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}