re = /(?:\/(.+?)){2}\//m
str = 'source = shuttle(Oct1-3).zip:./shuttle/5720/LOG/shuttle_log.20171002
source = shuttle_3.zip:./shuttle_3/5720/LOG/shuttle_log.20171011
source = shuttle_3.zip:./isNOT/shuttle_3/5720/LOG/shuttle_log.20171011'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end