#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*/test.*$"
Local $sString = " Garbage directory" & @CRLF & _
" /test/this/is/a/directory" & @CRLF & _
" /this/is/another/foo" & @CRLF & _
"Thisd is is" & @CRLF & _
"Drop stuff testing" & @CRLF & _
"Random stuff emacs is great"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")