using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*/test.*$";
string input = @" Garbage directory
/test/this/is/a/directory
/this/is/another/foo
Thisd is is
Drop stuff testing
Random stuff emacs is great";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}