re = /^\s*\/test.*$/m
str = ' Garbage directory
/test/this/is/a/directory
/this/is/another/foo
Thisd is is
Drop stuff testing
Random stuff emacs is great'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end