package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*/test.*$`)
var str = ` Garbage directory
/test/this/is/a/directory
/this/is/another/foo
Thisd is is
Drop stuff testing
Random stuff emacs is great`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}