$re = '~^\s*/test.*$~m';
$str = ' Garbage directory
/test/this/is/a/directory
/this/is/another/foo
Thisd is is
Drop stuff testing
Random stuff emacs is great';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);