using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Total[^$]+(.+)";
string input = @"Residue mmbtu 3,787.11 100.00% 3,787.11 $1.623163 $6,147.10
Total 3,787.11 3,787.11 $6,147.10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}