import re
regex = re.compile(r"^Total[^$]+(.+)", flags=re.MULTILINE)
test_str = ("Residue mmbtu 3,787.11 100.00% 3,787.11 $1.623163 $6,147.10 \n"
"Total 3,787.11 3,787.11 $6,147.10")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")