const regex = new RegExp('^Total[^$]+(.+)', 'gm')
const str = `Residue mmbtu 3,787.11 100.00% 3,787.11 \$1.623163 \$6,147.10
Total 3,787.11 3,787.11 \$6,147.10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}