use strict;
my $str = 'Residue mmbtu 3,787.11 100.00% 3,787.11 $1.623163 $6,147.10
Total 3,787.11 3,787.11 $6,147.10';
my $regex = qr/^Total[^$]+(.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}