package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Total[^$]+(.+)`)
var str = `Residue mmbtu 3,787.11 100.00% 3,787.11 $1.623163 $6,147.10
Total 3,787.11 3,787.11 $6,147.10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}