#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[wpadcenter_ad id=\d\d\d\d\d\d\d align=\'\w+\'\]"
Local $sString = "wpadcenter_display_ad( array( 'id' => 1243317, 'align' => 'none' ) );" & @CRLF & _
"[wpadcenter_ad id=1243317 align='none']" & @CRLF & _
"[extrenal_radio_player_scn]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")