import Foundation
let pattern = #"\[wpadcenter_ad id=\d\d\d\d\d\d\d align=\'\w+\'\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
wpadcenter_display_ad( array( 'id' => 1243317, 'align' => 'none' ) );
[wpadcenter_ad id=1243317 align='none']
[extrenal_radio_player_scn]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}