use strict;
my $str = 'wpadcenter_display_ad( array( \'id\' => 1243317, \'align\' => \'none\' ) );
[wpadcenter_ad id=1243317 align=\'none\']
[extrenal_radio_player_scn]
';
my $regex = qr/\[wpadcenter_ad id=\d\d\d\d\d\d\d align=\'\w+\'\]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}