$re = '/\[wpadcenter_ad id=\d\d\d\d\d\d\d align=\'\w+\'\]/';
$str = 'wpadcenter_display_ad( array( \'id\' => 1243317, \'align\' => \'none\' ) );
[wpadcenter_ad id=1243317 align=\'none\']
[extrenal_radio_player_scn]
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);