// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[wpadcenter_ad id=\d\d\d\d\d\d\d align=\'\w+\'\]").unwrap();
let string = "wpadcenter_display_ad( array( 'id' => 1243317, 'align' => 'none' ) );
[wpadcenter_ad id=1243317 align='none']
[extrenal_radio_player_scn]
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}