using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b\w*(\w)(?=[^\w\n]+\1)[^\w\n]+)+\w+";
string input = @"word""§$Dark!""§ king glow
word dark king glow we end
word dark king glow we end hello bye low wing
AB
A A
A B
AB B
AB BC D
AB BC CE
AB C
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}