import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b\\w*(\\w)(?=[^\\w\\n]+\\1)[^\\w\\n]+)+\\w+";
final String string = "word\"§$Dark!\"§ king glow\n"
+ "word dark king glow we end\n"
+ "word dark king glow we end hello bye low wing\n\n"
+ "AB\n"
+ "A A\n"
+ "A B\n"
+ "AB B\n"
+ "AB BC D\n"
+ "AB BC CE\n"
+ "AB C\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}