$re = '/(?:\b\w*(\w)(?=[^\w\n]+\1)[^\w\n]+)+\w+/mi';
$str = 'word"§$Dark!"§ king glow
word dark king glow we end
word dark king glow we end hello bye low wing
AB
A A
A B
AB B
AB BC D
AB BC CE
AB C
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);