const regex = /(?:\b\w*(\w)(?=[^\w\n]+\1)[^\w\n]+)+\w+/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b\\w*(\\w)(?=[^\\w\\n]+\\1)[^\\w\\n]+)+\\w+', 'gmi')
const str = `word"§\$Dark!"§ king glow
word dark king glow we end
word dark king glow we end hello bye low wing
AB
A A
A B
AB B
AB BC D
AB BC CE
AB C
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}