# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\b\w*(\w)(?=[^\w\n]+\1)[^\w\n]+)+\w+"
test_str = ("word\"§$Dark!\"§ king glow\n"
"word dark king glow we end\n"
"word dark king glow we end hello bye low wing\n\n"
"AB\n"
"A A\n"
"A B\n"
"AB B\n"
"AB BC D\n"
"AB BC CE\n"
"AB C\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.