use strict;
my $str = ' &example=1&';
my $regex = qr/(?:^|&)(example)=(1)(?:$|&)/mp;
my $subst = '\\1/\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";