import Foundation
let pattern = #"(?:^|&)(example)=(1)(?:$|&)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" &example=1&"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1/\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)