re = /(?:^|&)(example)=(1)(?:$|&)/m
str = ' &example=1&'
subst = '\\1/\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result