const regex = /(at){2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(at){2}', 'g')
const str = `There is nothing to match in this sentence because it doesn't have the repeating pattern. The pattern is the letters "at" together, using the parenthesis to group the letters we want to look for, repeated two times.
It will find a match in the following: "The machine gun went ratat."
No match here because of the spaces: "The machine gun went rat at"
This will partially match since it is looking for "at" twice in a row, but will not match the full repetition since it actually repeats three times: "The machine gun went ratatat." To fix this, we could change the expresion to "(at){2,}" which says find the letters "at" repeated two or more times.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}