use strict;
my $str = 'There is nothing to match in this sentence because it doesn\'t have the repeating pattern. The pattern is the letters "at" together, using the parenthesis to group the letters we want to look for, repeated two times.
It will find a match in the following: "The machine gun went ratat."
No match here because of the spaces: "The machine gun went rat at"
This will partially match since it is looking for "at" twice in a row, but will not match the full repetition since it actually repeats three times: "The machine gun went ratatat." To fix this, we could change the expresion to "(at){2,}" which says find the letters "at" repeated two or more times.';
my $regex = qr/(at){2}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}