#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*\/\/.*$|^\s*\/\*.*\*\/\s*$"
Local $sString = "// hello world" & @CRLF & _
" // some comment" & @CRLF & _
"/* other comment */" & @CRLF & _
" /* yet another one */ " & @CRLF & _
"" & @CRLF & _
"/* hello" & @CRLF & _
" * thing" & @CRLF & _
" bing" & @CRLF & _
" world */" & @CRLF & _
"" & @CRLF & _
"color: red; // red color" & @CRLF & _
"" & @CRLF & _
"// Variables" & @CRLF & _
"" & @CRLF & _
"// Greys" & @CRLF & _
"@linkColor: #000;" & @CRLF & _
"" & @CRLF & _
"// Links" & @CRLF & _
"@linkColorHover: darken(@linkColor, 15%);" & @CRLF & _
"" & @CRLF & _
"// Fonts" & @CRLF & _
"@sansFontFamily: "Helvetica Neue", Helvetica, Arial, sans-serif;" & @CRLF & _
"@altFontFamily: @sansFontFamily;" & @CRLF & _
"" & @CRLF & _
"// Size" & @CRLF & _
"@baseLineHeight: 20px;" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")