$re = '/^\s*\/\/.*$|^\s*\/\*.*\*\/\s*$/m';
$str = '// hello world
// some comment
/* other comment */
/* yet another one */
/* hello
* thing
bing
world */
color: red; // red color
// Variables
// Greys
@linkColor: #000;
// Links
@linkColorHover: darken(@linkColor, 15%);
// Fonts
@sansFontFamily: "Helvetica Neue", Helvetica, Arial, sans-serif;
@altFontFamily: @sansFontFamily;
// Size
@baseLineHeight: 20px;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);