import Foundation
let pattern = #"^\s*\/\/.*$|^\s*\/\*.*\*\/\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
// hello world
// some comment
/* other comment */
/* yet another one */
/* hello
* thing
bing
world */
color: red; // red color
// Variables
// Greys
@linkColor: #000;
// Links
@linkColorHover: darken(@linkColor, 15%);
// Fonts
@sansFontFamily: "Helvetica Neue", Helvetica, Arial, sans-serif;
@altFontFamily: @sansFontFamily;
// Size
@baseLineHeight: 20px;
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)