import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\/\\/.*$|^\\s*\\/\\*.*\\*\\/\\s*$";
final String string = "// hello world\n"
+ " // some comment\n"
+ "/* other comment */\n"
+ " /* yet another one */ \n\n"
+ "/* hello\n"
+ " * thing\n"
+ " bing\n"
+ " world */\n\n"
+ "color: red; // red color\n\n"
+ "// Variables\n\n"
+ "// Greys\n"
+ "@linkColor: #000;\n\n"
+ "// Links\n"
+ "@linkColorHover: darken(@linkColor, 15%);\n\n"
+ "// Fonts\n"
+ "@sansFontFamily: \"Helvetica Neue\", Helvetica, Arial, sans-serif;\n"
+ "@altFontFamily: @sansFontFamily;\n\n"
+ "// Size\n"
+ "@baseLineHeight: 20px;\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}