using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\/\/.*$|^\s*\/\*.*\*\/\s*$";
string input = @"// hello world
// some comment
/* other comment */
/* yet another one */
/* hello
* thing
bing
world */
color: red; // red color
// Variables
// Greys
@linkColor: #000;
// Links
@linkColorHover: darken(@linkColor, 15%);
// Fonts
@sansFontFamily: ""Helvetica Neue"", Helvetica, Arial, sans-serif;
@altFontFamily: @sansFontFamily;
// Size
@baseLineHeight: 20px;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}