#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xmu)^\s+<span.+lj:user="" & @CRLF & _
"([-\w]{1,15})" & @CRLF & _
"".+<b>" & @CRLF & _
"([-\w\s]+)" & @CRLF & _
"<\/b>.+ —\s" & @CRLF & _
"([-\.\w\s]+)" & @CRLF & _
"<\/div>$"
Local $sString = " <div>" & @CRLF & _
" <span class="ljuser i-ljuser i-ljuser-type-P " data-ljuser="canonf" lj:user="canonf" ><a href="http://canonf.livejournal.com/profile" target="_self" class="i-ljuser-profile" ><img class="i-ljuser-userhead" src="http://l-stat.livejournal.net/img/userinfo.gif?v=17080?v=134.3" /></a><a href="http://canonf.livejournal.com/" class="i-ljuser-username" target="_self" ><b>canonf</b></a></span> — Растоптать от души." & @CRLF & _
" </div>" & @CRLF & _
" <div>" & @CRLF & _
" <span class="ljuser i-ljuser i-ljuser-type-I " data-ljuser="ext_2056646" lj:user="ext_2056646" ><a href="http://www.livejournal.com/profile?userid=65329483&t=I" target="_self" class="i-ljuser-profile" ><img class="i-ljuser-userhead" src="http://l-stat.livejournal.net/img/icons/facebook-16.png?v=29916?v=134.3" /></a><a href="http://www.facebook.com/profile.php?id=100001197014517" class="i-ljuser-username" target="_self" ><b>Летающий Котёнок</b></a></span> — Растоптать от души." & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")